Hatena::ブログ(Diary)

日々勉強 このページをアンテナに追加 RSSフィード

2011-04-06 mongrel 実行時にLIBPQ.dllのエラーが発生する

ruby on rails をさわっていたら不可思議な現象に出くわしたのでメモ

| 17:50 | ruby on rails をさわっていたら不可思議な現象に出くわしたのでメモを含むブックマーク ruby on rails をさわっていたら不可思議な現象に出くわしたのでメモのブックマークコメント

■環境

Windows XP

ruby 1.8.7-p334

ruby on rails 2.3.11

mongrel 1.1.5

PostgreSQL 9.0.3


mongrelを起動時に以下のエラーが発生

ruby.exe - エントリ ポイントが見つかりません

---------------------------

プロシージャ エントリ ポイント PQconnectionNeedsPassword がダイナミック リンク ライブラリ LIBPQ.dll から見つかりませんでした。

■原因

よく解らないけどPostgreSQLインストール時に合わせてPostgreSQLODBCドライバも入れた事が原因みたい。

ためにし、c:\windows\system32 に入っているlibpq.dllを別の場所に移動した後にmongrel を実行するとエラーが発生しなくなりました。

libpq.dllが原因でエラーを出力してるみたいだけど・・・

別にエラーが表示されても、mongrel は正常に動作しているようなので、気にならない人は無視しても良いかもです。

トラックバック - http://d.hatena.ne.jp/Harusir/20110406/1302079823
リンク元