Hatena::ブログ(Diary)

Meguuの日記 RSSフィード

2007-02-20

[][][]Radiantのインストール

研究室ウェブサイトをRadiantで作ろう!ということで試しに遊ぶ。

Radiantとは

公式ウェブサイトRadiant CMS

Radiantの開発理念

Radiant is meant to be lean and mean. It's not like a lot of other content management systems which come with a bunch of generic bells and whistles. Large community oriented Web sites are way outside Radiant's problem domain. Such Web sites are almost always better built from the ground up with a Web framework like Ruby on Rails. Radiant tries to keep things simple and focuses on making it easy to publish content. It is well suited for small Web sites like blogs, portfolios, and small business sites, but not well suited for large "social" Web sites.

Radiant is simple on purpose, but this doesn't mean that you can't extend Radiant to meet your own needs. Radiant is designed to be extensible making it easy for you to write custom behaviors or text filters. Since it's built with Ruby on Rails you can also write a custom controller or two to handle what Radiant doesn't do right out of the box.

Yahoo!翻訳の訳をそれっぽく修正したもの

光点(Radiant)は、引き締まっているはずである。それは、たくさんの付属品で飾られた多くの他のCMSとは似ていない。大きなコミュニティにおけるウェブサイトは、Radiantでは取り扱わない。そのようなウェブサイトは、Ruby on Railsのようなウェブフレームワークで、最初から最後までたいていよりよく構築されている。Radiantはシンプル志向に努め、コンテンツを簡単に配信できる点にフォーカスを当てる。それは、ブログポートフォリオ中小企業サイトのような小さなウェブサイトに適しているが、大きな「ソーシャルウェブサイトには適していない。

Radiantはシンプルに作られているが、これはあなたがあなたのニーズに応ずるためにRadiantを拡張できないことを意味しない。Radiantは、カスタムBehaviorやテキストフィルタを簡単に書いて扱う事が出来るように設計されている。さらに、RadiantはRuby on Rails上で構築されているので、あなたはRadiantが予想していなかった独創的なカスタムControllerを書くことも出来る。

インストール

RubyGemsインストール

# gem install --remote radiant --include-dependencies

成功。

[][][]Ruby on Railsインストール

DebianのパッケージにRailsがあるか確認。→ない。

RailsウェブサイトによればRubyGemsインストール可。

RubyGemsウェブサイトよりRubyGemsダウンロード

展開し、セットアップ。

# ruby setup.rb

どうやらRDocが入っていないらしい。

ドキュメントを見ると他にも色々要りそうだ。

Debian Linux: Debian does not automatically include all the standard Ruby libararies in the basic Ruby package. As a result, you may need to ’’apt-get’’ libyaml-ruby and libzlib-ruby before you can install rubygems.

それらをインストール

# apt-get install rdoc

# apt-get install libyaml-ruby

# apt-get install libzlib-ruby

そしてセットアップ。

# ruby setup.rb

成功。

Railsウェブサイトに書いてある通りにコマンドを実行するがエラー。

# gem install rails --include-dependencies

ERROR: While executing gem ... (Gem::GemNotFoundException)

Could not find rails (> 0) in any repository

RubyGemsウェブサイトによれば、リモートインストールにはコマンドラインオプションが必要。

# gem install --remote rails --include-dependencies

成功。

Connection: close