身の回り4畳半近辺の日記

2004 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2005 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2006 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2007 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2008 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2009 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2010 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2011 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2012 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2013 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2014 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2015 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2016 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2017 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2018 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 |
プロフィール

b3g


適当に日々思ったことを書いているだけですのであまりお役に立てないと思いますが、検索サイトから訪問された方で目的の情報が見あたらない場合は、上の検索にて「日記」ボタンをお使いください。


 | 

2017-05-20 モニターのDP1.2有効化は注意

b3g2017-05-20

[]

 1週間ほど前に会社で使用しているDell Precision Tower 3620の新しいBIOSバージョン2.3.0が公開されていましてこの週末に適用してみました。このBIOSですが例のIntel AMT脆弱性CVE-2017-5689に対応したものとのこと。

 Windows 10インストールしたマシンではアップデート完了後、再起動しても問題ないようです。ということで他のWindows 7マシンに導入したところ問題が。再起動後にビープ音が1回鳴って画面が出てきません。その後Windowsが通常起動していつもの解像度になれば表示されるのですが、それまではビデオ信号から出ていない状況です。

 このPrecision Tower 3620はNVIDIAQuadro M4000を接続していてそこからモニターに接続していますオンボードDisplayPort端子もあるのでそちらからなら見えるかも、と接続し直してもビデオ信号が出ていませんでした。BIOSの設定でビデオ出力先の優先を決めれますBIOS画面自体が見えないのでどうしようもなく、そもそもオンボード側も拡張ボード側も信号が出てないようです。このままでもWindowsが起動してしまえば使用問題ないのですが何かあったときBIOS画面が見えないのは致命的です。

 ということでBIOSをダウングレードしようと元のバージョンインストールしたのですが、前のインストールexeを実行して再起動しても古いBIOS更新されませんでした。ダウングレードの場合再起動後なにかキー入力必要でしたっけ。起動後は画面が表示されないので確認のしようがありません。

 これは久しぶりにヤバイ感じです。デルPCBIOSがマズイときリカバリーする方法はないものかと検索するとこちらのページがありました。2015年以降のモデル限定されますが起動時にCtrlとESCキーを同時押しでBIOS Recovery画面になるとのこと。最後の望みでやってみたところ、なんとかその画面が表示されるようになりました。結構、長めに1分はないけれども30秒ぐらい押しっぱなしで画面が表示されました。1回ではだめならコンセントを抜いて2回目でようやく表示されたパターンもあります。ともかくRecovery画面が表示されれば前のBIOSに戻す選択肢があるので、それを選んで再起動バージョン2.1.9の状態に戻りました。起動時の画面表示も問題なしです。

 マシン構成は同じなのにWindows 10OKWindows 7NGなのはなんででしょうね。BIOS設定で違う点はWin10がSecure Boot EnableEnableEnable Legacy Option ROMsがDisable。WIn7は逆にSecure Boot EnableがDisableでEnable Legacy Option ROMsがEnableなぐらいなのですが。ともかくこのデルバージョン2.3.0のBIOSですがUEIFでの画面表示にバグがあると推測されます

追記

 この現象ですがさらに調べて原因はBIOSにだけにあるのではなく、接続しているデルモニターU2715Hか、ビデオボードQuadro M4000もあやしいです。本体DPとモニターmDPで接続して上記のような状態ですが試しに本体DPからDVI変換して他のモニターDVI接続してみたら普通にBIOS画面が表示されました。

 どちらもハードウェアが要因なので簡単にはなおらないでしょうね。

さらに追記

 この問題、原因が判明しました。モニターU2715HのDP1.2をオンにしていると問題が発生し、オフでは問題なく画面表示されます

 ビデオボード、モニターともにDP1.2に対応しているなら有効にしておこうかぐらいの気持ちで設定していました。こちらのページによるとU2715の最適解像度2560X1440 (60Hz)ではDP1.0でもOKとのことでDP1.2オフでもなんら問題ありません。

 | 

アクセス数:2798867 (2004.4.16よりカウンタ開始)