Hatena::ブログ(Diary)

くりまるwebつくる

ふぅ、疲れた。今日はここまで。
カレンダー
2008 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2009 | 01 | 02 | 03 | 04 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2010 | 01 |

2008年03月26日

[][][]xenで作ってもらった新しい鯖でrails+mysql入れる

rubyダウンロード

yumがruby1.8.5しかないみたい。

1.8.6じゃないとGetTextとRails2.xでなんかよくないとかどっかで見たので、1.8.6が入れたい。

なので、落としてきて入れる。

wget ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.6-p114.tar.bz2
wget http://rubyforge.org/frs/download.php/29548/rubygems-1.0.1.tgz

tar jxvf ruby-1.8.6-p114.tar.bz2 
tar zxvf rubygems-1.0.1.tgz

configureしてmake

しよーと思ったらchecking for gcc... noとか言われたTT なので

yum install gcc

で./configureできるようになった。

無事にconfig.status: creating Makefileになったのでmake

rubygemsもsetup.rbでインストール

mysql入れる

yum install mysql mysql-server

起動

/etc/rc.d/init.d/mysqld start

rails入れる

gem install rails

したら、zlibがどーたら文句言われた

# gem install help
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- zlib (LoadError)

zlib-develが入ってなかったから入れてみる

yum install zlib-devel

ってやっても、うごかねー

Rubyの最新版を入れる - uzullaの日記 - 1981s

を参考に

# cd /home/crimaru/src/ruby-1.8.6-p114/ext/zlib/
# ruby extconf.rb
# gem install rails
Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed rake-0.8.1
Successfully installed activesupport-2.0.2
Successfully installed activerecord-2.0.2
Successfully installed actionpack-2.0.2
Successfully installed actionmailer-2.0.2
Successfully installed activeresource-2.0.2
Successfully installed rails-2.0.2
7 gems installed
Installing ri documentation for rake-0.8.1...
Installing ri documentation for activesupport-2.0.2...
以下略

うごいたー

今回使うgem入れる

gem install hpricot
gem install mechanize
gem install ruby-openid
gem install openid_login_generator
gem install ruby-yadis
gem install mongrel
gem install capistrano

で大体こんなもん

# gem list --local

*** LOCAL GEMS ***

actionmailer (2.0.2)
actionpack (2.0.2)
activerecord (2.0.2)
activeresource (2.0.2)
activesupport (2.0.2)
capistrano (2.2.0)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
gettext (1.90.0)
highline (1.4.0)
hoe (1.5.1)
hpricot (0.6)
mechanize (0.7.5)
mongrel (1.1.4)
needle (1.3.0)
net-sftp (1.1.1)
net-ssh (1.1.2)
openid_login_generator (0.1)
rails (2.0.2)
rake (0.8.1)
ruby-openid (2.0.4)
ruby-yadis (0.3.4)
rubyforge (0.4.5)

試しにプロジェクトつくってサーバーでも起動してみる

rails test
cd test
mongrel_rails start

** Starting Rails with development environment...
/usr/local/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in `require_frameworks': no such file to load -- openssl (RuntimeError)

opensslがないと文句言われたので入れる

yum install openssl openssl-devel

で、ダメ。

zlibと一緒だわ。

2008-03-10 - Hexaの日記を参考に

cd /home/crimaru/src/ruby-1.8.6-p114/ext/openssl/
ruby extconf.rb
make
make install

cd /home/crimaru/src/ruby-1.8.6-p114/
make clean
./configure
make
make install

# mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  TERM => stop.  USR2 => restart.  INT => stop (no restart).
** Rails signals registered.  HUP => reload (without restart).  It might not work well.
** Mongrel 1.1.4 available at 0.0.0.0:3000
** Use CTRL-C to stop.

なんとか動いた。

とりあえず、ローカルで作ってた奴をあげた

コンテンツ上げる

database.ymlを編集(今回はしなくてよかった)

/etc/rc.d/init.d/mysqld start

rake db:create

rake db:migrate

で、動いた。

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/crimaru/20080326/1206495578