Hatena::ブログ(Diary)

試したこととか困ったこととか

2015-01-08

Vagnrat上のCentOS6.5にChromeをインストールしたい


CentOS 6.2 に Chrome をインストールする


/etc/yum.repos.d/google-chorme.repo を作成します。
手動で作成します。

sudo vim /etc/yum.repos.d/google-chorme.repo


64 bit 版の場合
/etc/yum.repos.d/google-chorme.repo に以下の内容を書き込みます。
[google-chrome]

name=google-chrome - 64-bit
baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64
enabled=1
gpgcheck=1
gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub



インストール可能なパッケージを調べます。

sodo yum list '*chrome*'



google-chrome-beta.x86_64 40.0.2214.69-1 google-chrome
google-chrome-stable.x86_64 39.0.2171.95-1 google-chrome
google-chrome-unstable.x86_64 41.0.2267.0-1 google-chrome
xorg-x11-drv-openchrome.i686 0.3.3-6.el6 base
xorg-x11-drv-openchrome-devel.i686 0.3.3-6.el6 base
xorg-x11-drv-openchrome-devel.x86_64 0.3.3-6.el6 base


stableをインストールします。

sudo yum install -y 'google-chrome-stable.x86_64'


依存ライブラリが足りない

Error: Package: google-chrome-stable-39.0.2171.95-1.x86_64 (google-chrome)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


依存ライブラリを追加

sudo yum install -y libstdc++


間違えたので再実行

sudo yum install -y libstdc++.so.6


ダメだった。

こっちが正解らしい。

Google Chrome 60 Released - Install on RHEL/CentOS 7/6 and Fedora 26-20

まずwgetの入手

sudo yum install -y wget


chromeインストールシェルの入手

# wget http://chrome.richardlloyd.org.uk/install_chrome.sh
# chmod u+x install_chrome.sh
# sudo ./install_chrome.sh


インストール完了

Please run the browser via the 'google-chrome' command as a non-root user.

To update Google Chrome, run "yum update google-chrome-stable" or
simply re-run this script with "./install_chrome.sh".

To uninstall Google Chrome and its dependencies added by this script,
run "yum remove google-chrome-stable chrome-deps-stable" or "./install_chrome.sh -u".

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/eerga/20150108/1420679355