Hatena::ブログ(Diary)

Rubyとか Illustratorとか SFとか折紙とか このページをアンテナに追加 RSSフィード

2008-12-06

Rails 2.2.2 と RubyGems 1.3.1 と rubygems-update

| 19:12 | Rails 2.2.2 と RubyGems 1.3.1 と rubygems-updateを含むブックマーク Rails 2.2.2 と RubyGems 1.3.1 と rubygems-updateのブックマークコメント

(/12/7 タイトル誤記修正「1.3.1」<-「1.3.1 1」)

Rails 2.2.2 だと RubyGems は 1.3.1 以上を要求する

[2810] script/server               ~/rails/222 18:50 1206
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again.

だが、普通にそうしてもそうならない。

[2811] gem update --system         ~/rails/222 18:50 1206
Updating RubyGems
Nothing to update

rubygems-update すれば良いらしい

[2812] gem list -r rubygems-update

			
REMOTE GEMS ***
rubygems-update (1.3.1)
(1)hs9587@vmw-rrrmagic[2818] sudo gem install rubygems-update
Successfully installed rubygems-update-1.3.1
1 gem installed
(1)hs9587@vmw-rrrmagic[2819] gem --version               ~/rails/222 18:55 1206
1.2.0
[2822] sudo update_rubygems 
 云々
[2822] gem --version               ~/rails/222 18:58 1206
1.3.1

script/server も動く。

Windowsの場合もコマンドプロンプトで単に「update_rubygems」としてインストール(アップデート)出来た(十分な権限のあるユーザ)。