Hatena::ブログ(Diary)

jitsu102の日記 このページをアンテナに追加 RSSフィード Twitter

2007 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2008 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2009 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2010 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2011 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 10 | 11 | 12 |
2012 | 01 | 02 | 03 |

2009-08-03

DebianのRubyGemsをアップデート

Debian LennyRubyGemsが1.2.0と古かったので、アップデートしました。

Debianでは、rubygems-updateを使うようです。

ちなみに、通常の方法でRubyGemsアップデートしようとすると、

$ sudo gem update --system
ERROR:  While executing gem ... (RuntimeError)
    gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories by aptitude or apt-get.

怒られます><

ということで、まずはrubygems-updateをインストールします。

rubygems-updateの最新バージョンは1.3.5(2009.08現在)なのですが、rubygems-update 1.3.5を動かすにはrubygems 1.3.1以上が必要になるという、よく分からない状況になりますので、rubygems-updateは1.3.1をインストールします。

$ gem query -rn rubygems-update

*** REMOTE GEMS ***

rubygems-update (1.3.5)   ### 最新版は、1.3.5
$ sudo gem install rubygems-update -v 1.3.1   ### 今回は、1.3.1をインストール
Successfully installed rubygems-update-1.3.1
1 gem installed

次に、update_rubygemsを実行します。

$ sudo /var/lib/gems/1.8/bin/update_rubygems 
Installing RubyGems 1.3.1
(省略)

確認。

$ gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.1
  - RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]
(省略)

kumonopanyakumonopanya 2009/09/19 15:39 助かりました、gem1.3.1からgem1.3.5へ無事アップデートできました。

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証