Hatena::ブログ(Diary)

MOVE-i このページをアンテナに追加 RSSフィード

2010-07-19

[][]Gaelyk template projectバージョンアップ!

http://gaelyk.appspot.com/download

Gaelykが、0.4.2にバージョンアップしていたようで、ぼくの使ってるのは、0.3.2。groovyのバージョンも1.7.3にアップしたかったので、テンプレートをダウンロードして、全体的にローカルのGaelykアプリをバージョンアップさせようと思った。

基本的には0.4.2テンプレート、WEB-INF/lib配下のファイルの"appengine-api-1.0-sdk-1.3.5.jar" "appengine-api-labs-1.3.5.jar" "gaelyk-0.4.2.jar" "groovy-all-1.7.3.jar"、4つのJARを古いのと置き換えれば良いだけかなと思って、置き換え後動かしてみたら。。

2010/07/19 10:53:49 com.google.apphosting.utils.jetty.JettyLogger warn
?x??: Error for /crud.groovy
java.lang.NoSuchMethodError: com.google.apphosting.api.ApiProxy.makeSyncCall(Ljava/lang/String;
Ljava/lang/String;[BLcom/google/apphosting/api/ApiProxy$ApiConfig;)[B
	at com.google.appengine.api.datastore.DatastoreApiHelper.makeSyncCall(DatastoreApiHelper.java:58)
	at com.google.appengine.api.datastore.DatastoreServiceImpl$2.run(DatastoreServiceImpl.java:188)
	at com.google.appengine.api.datastore.TransactionRunner.runInTransaction(TransactionRunner.java:30)
	at com.google.appengine.api.datastore.DatastoreServiceImpl.put(DatastoreServiceImpl.java:176)
	at com.google.appengine.api.datastore.DatastoreServiceImpl.put(DatastoreServiceImpl.java:156)
	at com.google.appengine.api.datastore.DatastoreServiceImpl.put(DatastoreServiceImpl.java:148)
(省略)

クエリを実行しているところでエラーが出ているようで。。googleで検索しても、解決方法見つからず、あとで、crudアプリの作り方を勉強しなおそう。