Hatena::ブログ(Diary)

kuma8の日記 RSSフィード

2007-07-12

[] lxmlがインストールできない

lxml 1.3がFedora7でなぜかインストールできない。

ライブラリの要件は、満たしているんだけどなぁ

easy_install, コンパイルともにNG

yumで、逃げるか・・ lxml 1.1.2になるけど

必要なライブラリは、

You need Python 2.3 or later.

You need libxml2 and libxslt, in particular:

: libxml 2.6.20 or later. It can be found here:

http://xmlsoft.org/downloads.html

If you want to use XPath reliably, try to avoid libxml2 2.6.27.

: libxslt 1.1.15 or later. It can be found here:

http://xmlsoft.org/XSLT/downloads.html

Fedora 7 (現状)

libxml2-devel-2.6.29-1.fc7

libxml2-2.6.29-1.fc7

libxml2-python-2.6.29-1.fc7

libxslt-python-1.1.21-1.fc7

libxslt-1.1.21-1.fc7

<追記>

libxslt-devel が抜けていました。

aodagさんに感謝。

aodagaodag 2007/07/12 23:30 該当する環境を持っていないので、的外れかもしれませんが、libxsltのdevelはいらないのでしょうか.

kuma8kuma8 2007/07/12 23:42 ずばり、それでした。 サンクスです。

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

Connection: close