Hatena::ブログ(Diary)

journal de kyart プログラマ/通訳の備忘録 このページをアンテナに追加

2008-10-31

apt-get updateで"この APT が対応している以上の数の説明が要求されました。"というエラー

| 03:13 |

新しくインストールしたLinuxDebian)でapt-get updateでリストを更新しようとすると、

パッケージリストを読み込んでいます... エラー!
E: この APT が対応している以上の数の説明が要求されました。
E: Problem with MergeList /var/lib/apt/lists/ftp.jp.debian.org_debian_dists_.._project_experimental_main_binary-i386_Packages
E: パッケージリストまたはステータスファイルを解釈またはオープンすることができません。
root@windhoek:/var/lib/apt/lists# apt-cache policy apt
E: この APT が対応している以上の数の説明が要求されました。
licy aptdhoek:/var/lib/apt/lists# apt-cache -o APT::Acquire::Translation=none po 

というエラーが発生。

/var/lib/apt/lists

の中身を、particialというディレクトリだけを残して削除し、(一応バックアップを取って)以下のコマンドでapt-getを実行する。

apt-get update -o APT::Acquire::Translation=none

これでエラーを回避できた。

トラックバック - http://d.hatena.ne.jp/kyart/20081031/1225390410
Connection: close