Hatena::ブログ(Diary)

masomi79の日記 このページをアンテナに追加 RSSフィード

2018-03-22 管理画面を判定する

[] 13:54 を含むブックマーク のブックマークコメント

if(is_admin())

2018-02-13 アタッチメントIDから画像のURLを取得

masomi792018-02-13

[] 15:06 を含むブックマーク のブックマークコメント

<?php echo wp_get_attachment_url( 12 ); ?> 

2018-01-30 macへnodeをインストール このエントリーを含むブックマーク このエントリーのブックマークコメント

masomi792018-01-30
brew install node

ところが

node already installed, it's just not linked

インストールはできたけどリンクされてないから使えないよ!と。。

なおかつリンクを上書きするといいよ!

と言われるので

brew link --overwrite node

とするも、弾かれてしまう。。



下記で解決



brew uninstall node
 いったんアンインストール
brew update
brew upgrade
 Homebrewを最新に

brew cleanup
 いらないものを消す

brew install node
 もっかいインストール

sudo chown -R $(whoami) /usr/local/
 リンクが書いてあるファイルを上書きできるように権限を変更
 
brew link --overwrite node
 リンクを上書き

brew postinstall node
 これは何かよくわからない

2017-11-02 [mac] OSアップデートしてsassが使えなくなったら このエントリーを含むブックマーク このエントリーのブックマークコメント

masomi792017-11-02

::症状::

新規案件に着手する前にOSXをHigh Sierraアップデートしたらsass が使えない!急いでるのに!


sass -v

バージョン確認しようとしただけで。。。

-bash: /usr/local/bin/sass: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby: bad interpreter: No such file or directory

とおこられる。





::対策::

1.XCODEアップデート

App Storeから行います。



2.ターミナルからRubyを再インストール

brew install rbenv ruby-build


3.sass とcompassを /usr/local/binへインストール

sudo gem install -n /usr/local/bin sass
sudo gem install -n /usr/local/bin compass



というわけでアップデートは慎重に。。。

”High Sierra”ってなんで英語+スペイン語

2016-06-21 記事の抜粋を表示する このエントリーを含むブックマーク このエントリーのブックマークコメント

masomi792016-06-21

<?php echo mb_substr(strip_tags($post-> post_content), 0, 75); ?>

Connection: close