Hatena::ブログ(Diary)

mizchi log

@mizchiの雑記帳

2011-01-15

sbtでscala-android (SDK r8)


r8から android target listのバージョン指定の書式が変わってるのでめんどい

$ brew install sbt # or other way
$ cd ~/bin
$ wget --no-check-certificate https://github.com/jberkel/android-plugin/raw/master/script/create_project
$ chmod +x create_project
$ export ANDROID_SDK_HOME=/Users/mzi/android-sdk
$ ln -s /Users/mzi/android-sdk/platform-tools/adb /Users/mzi/android-sdk/tools/
$ ./create_project HelloAndroid org.mizchi.helloandroid --platform android-8 --scala-version 2.8.0.RC7 --activity HelloAndroid
$ vim platform/build/HelloAndroid.scala # Android-2.1 => Android-8(if target is android2.2 cf.android target list )
$ sbt
> compile
> install-device


なんか色々面倒ですね!!!!!