Hatena::ブログ(Diary)

Ruby Study Go RSSフィード

2008-10-12

UbuntuにRMagickをインストール

Ubuntu8.04の場合。

ImageMagickをインストール

% sudu apt-get install make
% sudo apt-get install imagemagick libmagick++9-dev

確認

% convert --version
Version: ImageMagick 6.3.7 02/19/08 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

Rubyをインストール

% sudo aptitude install ruby rubygems irb ruby1.8-dev

rmagickのコンパイルにruby1.8-devが必要らしい。

rubygemsを利用するための環境変数を設定

% export GEM_HOME=/var/lib/gems/1.8
% export RUBY_LIB=/usr/lib

RMagickをインストール

% sudu gem install rmagick
Building native extensions.  This could take a while...
Successfully installed rmagick-2.7.0

RubyからRMagickを呼び出せるか確認

% ruby -e "require'rubygems';require'RMagick'"

※ RMagickはコンパイルしてインストールされるのでmakeやlibmagick++9-devが必要になる。


Ubuntu 7.10の場合はリポジトリに用意されているImagemagickのバージョンが古い(Ver6.0.x系)なので、それにあわせてRMagickのバージョンも1系を指定しないとエラーがでる。

% sudo gem install rmagick -v 1.15.14 --no-rdoc

参考リンク

http://www.imagemagick.org/script/index.php

http://rmagick.rubyforge.org/

通りすがり通りすがり 2009/02/02 01:06 Imagemagickをインストールのところで、

sudo apt-get

となるはずが

sudo apt-gem

になっています。

ネタだったらすいません。

mostlyfinemostlyfine 2009/02/02 10:23 ネタじゃないっす(^^;;

修正しました。
ご指摘ありがとうございます!

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証