Hatena::ブログ(Diary)

leftovers... このページをアンテナに追加 RSSフィード

2014-05-22

Grails 2.3.9 バグフィックスリリース!!

Grails 2.3系 バグフィックス版 2.3.9 リリース


昨日 Grails 2.4が出たので、新たに始めよう!って人は悩みどころですね。


きっと2.3.10もあるだろうし。


え?まだ 2.2系使ってる?



Grails前バージョンからアップデートする場合は、Hibernateプラグインのバージョンを 3.6.10.15にしましょう!

Hbernate4の場合は4.3.5.3です。

Tomcatプラグインは7.0.52.1です。

build ':tomcat:7.0.52.1'
runtime ':hibernate:3.6.10.14' // ':hibernate4:4.3.5.1' for Hibernate 4

2.3.8以前から更新する場合は、resourcesプラグイン、scaffoldingプラグインの変更もしてね。

runtime ':resources:1.2.7'
compile ':scaffolding:2.0.3'

あと、database-migrationプラグインが今回更新で、Hibernate4にも対応しました。使用している方でHibernate4を使う場合は、バージョン1.4.0にしましょう。

runtime ':database-migration:1.4.0'

Grails 2.3.9 の公式リリースノートはこちら。

http://grails.org/2.3.9+Release+Notes

JIRA http://jira.grails.org/secure/ReleaseNote.jspa?projectId=10020&version=13707

ダウンロード http://grails.org/Download

直リン grails-2.3.9.zip

ドキュメント http://grails.org/doc/2.3.9/

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/mottsnite/20140522/1400770524