Hatena::ブログ(Diary)

leftovers... このページをアンテナに追加 RSSフィード

2014-06-26

Grails 2.4.2 と Grails 2.3.11 バグフィックスリリース!!

今回もダブルでバグフィックスリリースです。



今回リリースが前倒しになったのは、シャットダウン問題の解決のためです。

コチラの内容:https://jira.grails.org/browse/GRAILS-11514


そして、今回Mavenプラグイン 2.4.2 もリリースされました。これは、2.3系での問題点修正した内容になっています。

詳細はこちら https://jira.grails.org/browse/MAVEN-243



先ずは、

Grails 2.4.2 バグフィックスリリース

そもそも、Grails 2.4.xて何?って人はコチラもチェック!

Grails 2.4.0 リリースきた!!!!


Grails 2.4.1からアップデートする場合は、もろもろプラグインのバージョンを更新しましょう。

Hibernateプラグインに関しては必須です。

runtime ':hibernate4:4.3.5.4' // or ':hibernate:3.6.10.16'

以下のプラグイン更新推奨です。

build ':tomcat:7.0.54'
compile ':scaffolding:2.1.1'
compile ':asset-pipeline:1.8.11'


Grails 2.4.2 の公式リリースノートはこちら。

http://grails.org/2.4.2+Release+Notes

JIRA http://jira.grails.org/secure/ReleaseNote.jspa?projectId=10020&version=13812

ダウンロード http://grails.org/Download

直リン grails-2.4.2.zip

ドキュメント http://grails.org/doc/2.4.2/







Grails 2.3.11 バグフィックスリリース


こちらも、バグフィックスです。上記の2.4の内容を参照してね。



前バージョンからアップデートする場合は、Hibernateプラグインのバージョンを 3.6.10.16にしましょう!

Hbernate4の場合は4.3.5.4です。

build ':tomcat:7.0.54'
runtime ':hibernate:3.6.10.16' // ':hibernate4:4.3.5.4' for Hibernate 4

2.3.10以前から更新する場合は、resourcesプラグイン、scaffoldingプラグインの変更もしてね。

runtime ':resources:1.2.8'
compile ':scaffolding:2.0.3'

あと、database-migrationプラグインが今回更新で、Hibernate4にも対応しました。使用している方でHibernate4を使う場合は、バージョン1.4.0にしましょう。

runtime ':database-migration:1.4.0'

Grails 2.3.11 の公式リリースノートはこちら。

http://grails.org/2.3.11+Release+Notes

JIRA http://jira.grails.org/secure/ReleaseNote.jspa?projectId=10020&version=13813

ダウンロード http://grails.org/Download

直リン grails-2.3.11.zip

ドキュメント http://grails.org/doc/2.3.11/

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/mottsnite/20140626/1403777424
リンク元