ぐらめぬ・ぜぷつぇんのはてダ

2008/11/24以降のメインブログはこちらになります。 : http://www.glamenv-septzen.net/

本はてなダイアリにはコメント・トラックバックを受け付ける記事を公開します。

2008-10-26

[]今更 PHP4.4.9 にアップグレードしたら、"LIBPQ.dllが見つかりません" でへこんだ。

仕事上PHP4に触る機会がまだまだあります。またPHP4のサーバー自体はあと1〜2年はしぶとく生き残ると見ていますので、YakiBikiとかも相変わらずPHP4で動作確認したりしてます。

で、PHP4.4.8からPHP4.4.9にアップグレードしたら "LIBPQ.dll"が見つからないとかで怒られてました。

というわけで、PostgreSQL8.1を入れていたのでそのbinディレクトリから libpq.dll を C:\WINDOWS 以下にコピーしました。

ところが今度は "comerr32.dll" が見つからないとか怒られた。

。゚(゚´Д`゚)゚。

まぁ、

If something is stupid is the fact to (still) use php4. What do you need

to understand that we do not support php 4.x anymore? That we will not

fix anybug, we will not release it anymore, never.

PHP :: Bug #45771 :: Cannot load php_pgsql.dll

とあるとおり今時PHP4.xを使う方が悪いんですけどね。

しょうがないので、backupしておいたPHP4.4.8の php_pgsql.dll をPHP4.4.9にコピーしてみたら、エラーは無くなりました。本質的な問題はPHP4.xを使っているところが問題なのですが、ローカルで動作確認や実験をするだけという言い訳を以て、これで良しとしておきます。

っつーか、仕事で触っているのが大昔に作ったPHPアプリで、未だに拡張子が".php3"だったりします。中身はPHP4に直してますが。

はてなユーザーのみコメントできます。はてなへログインもしくは新規登録をおこなってください。

トラックバック - http://d.hatena.ne.jp/msakamoto-sf/20081026/1224994845