Hatena::ブログ(Diary)

mteramotoの日記 RSSフィード Twitter

2013-05-05

netatalk 3.0.1から3.0.3へのアップグレードが失敗する

netatalk 3.0.3がportsになっていたのでportupgradeを使ってアップグレードしようとしたら、build errorでmakeが失敗した。

afp_config.c: In function 'configinit':
afp_config.c:136: error: too few arguments to function 'load_volumes'
gmake[3]: *** [afpd-afp_config.o] Error 1
gmake[3]: Leaving directory `/usr/ports/net/netatalk3/work/netatalk-3.0.1/etc/afpd'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/net/netatalk3/work/netatalk-3.0.1/etc'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/net/netatalk3/work/netatalk-3.0.1'
gmake: *** [all] Error 2
*** [do-build] Error code 1

エラーメッセージはこんなかんじ。

ざっと調査したところ、共有ライブラリの問題だったので、古いnetatalk 3.0.1をアンインストールしてから3.0.3をインストールして解決した。

後から気づいたけど、PRになってた。Googleでは引っかからなかったので気づかなかったよ。

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/mteramoto/20130505/1367765957