昨日の肉まん

2006-12-04

[][]古いバージョンのGCCインストールする

 一時的に古いバージョンのGCCが必要になった。その時におこなったインストール手順。


インストール手順

 GCC, the GNU Compiler Collectionからgcc-3.4.0.tar.bz2をダウンロードする。

 以下のコマンドを実行する。

$ tar xlvf gcc-3.4.0.tar.bz2
$ cd gcc-3.4.0
$ mkdir build
$ cd build
$ ../configure --prefix=/usr/local/gcc-3.4.0 --enable-languages=c,c++ --enable-shared --enable-threads
$ make bootstrap
$ su
# make install

 最後にパスを通す。

$ export /usr/local/gcc-3.4.0/bin:$PATH

 $ gcc -v で確認すると3.4になっている。


 今回はCとC++だけをインストールした。全ての言語をインストールしたいなら --enable-languages=c,c++ を削除する。

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/nikumanhr/20061204/1165258010
リンク元