Hatena::ブログ(Diary)

日々の記録 別館

2012-06-05

textsearch_groonga

textsearch_groongaを9.1.4にインストールしてみる(9.2についてはrcがリリースされたら試してみる予定)。

とりあえずPostgreSQL 9.1.4とgroongaの最新版(2.0.3)をインストールして、textsearch_groongaをインストールしようとしたがこんなエラーが発生してビルドで失敗する(´・ω・`)

textsearch_groonga.c:241: error: ‘grn_query’ undeclared (first use in this function)

groonga.hを見てみると確かにそんな構造体はない・・・。で、groongaのリリースノートを見ると

非推奨となっていたgrn_queryを削除した。 [#1247]

と書いてある。つまり、現状のtextsearch_groongaはgroongaの2.0系では使えないってことになるのか。ぐぬぬ・・・。

結局、groongaの1.3.0(1.3.1のヘッダもgrn_queryがないのでエラーになる)をビルドインストールして、なんとかビルドは出来たが・・・。textsearch_groongaは最近はメンテナンスされていないのかな?

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/nuko_yokohama/20120605/1338886238