Hatena::ブログ(Diary)

pgmgontaの日記

2011-10-08

rvmで複数のrubyバージョンを管理する

rvmで複数のrubyバージョンを管理します。OSCentOSです。

1.rvmのインストール

rvmをインストールして、コマンドをPATHに通します。

cd ~
curl -s https://rvm.beginrescueend.com/install/rvm > rvm-install.sh
chmod +x  rvm-install.sh
./rvm-install.sh
echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" #load rvm function ' >> ~/.bash_profile
. ~/.bash_profile

2.Rubyのインストール

ここでは、rubyの1.9.2をインストールします。

rvm install 1.9.2

3.Rubyの選択

rvm use 1.9.2

以下のコマンドでRubyのバージョンを確認します。

ruby -v 

これで、1.9.2のRubyを使うことができます。1.8.7をつかう場合は、2.と3.の手順で1.8.7を指定してください。

トラックバック - http://d.hatena.ne.jp/pgmgonta/20111008/1318052276
リンク元