Hatena::ブログ(Diary)

プログラミングお勉強きろく RSSフィード

2012-02-27

yesod0.10をいれてcabal installしたらコケた問題

開発環境:mac、ghc7.0.4

新しく作ったyesodプロジェクトで、cabal installすると下記エラーがでた。

Resolving dependencies...
Configuring language-javascript-0.4.9...
cabal: The program alex version >=3.0 is required but the version found at
/usr/bin/alex is version 2.3.5
cabal: Error: some packages failed to install:
happiage-0.0.0 depends on language-javascript-0.4.9 which failed to install.
hjsmin-0.0.15 depends on language-javascript-0.4.9 which failed to install.
language-javascript-0.4.9 failed during the configure step. The exception was:
ExitFailure 1

cabal install alexして、バージョン3.0以上のalexを持ってくる。

/usr/bin/alexを、持ってきたalex実行ファイルに置き換えて、もういっかいcabal installしたらできた!

yesodは設定でいろいろコケるけど、たいへん素晴らしいwebフレームワークなので、どこかでチュートリアル的な記事書きたいところ。

スパム対策のためのダミーです。もし見えても何も入力しないでください
ゲスト


画像認証

トラックバック - http://d.hatena.ne.jp/syoko_sasaki/20120227/1330312921
リンク元