Hatena::ブログ(Diary)

第2.5地区 RSSフィード Twitter

f:id:taramonera:20101126204352g:image
ブログ引っ越しました。→ http://taramonera.net/2.5/

2012-10-26

さくらインターネット スタンダードでPHPのバージョンを5.2から5.3に変更

| 16:23 |

さくらインターネット スタンダードでPHPのバージョンを5.2から5.3に変更

コントロールパネルの「PHPのバージョン選択」をクリック

f:id:taramonera:20121026162321j:image


PHP 5.3.17を選択し、変更ボタンをクリックするだけ

f:id:taramonera:20121026162322j:image


5.2で動かしていたプログラムを実行すると下記のエラーがでた
Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Asia/Tokyo' for 'JST/9.0/no DST' instead in /home/xxx/index.php on line 286

timezoneの設定が必要なようなので、「PHP設定の編集」をクリック

f:id:taramonera:20121026162323j:image


timezoneに「Asia/Tokyo」を追加して保存

f:id:taramonera:20121026162909j:image

トラックバック - http://d.hatena.ne.jp/taramonera/20121026/1351236212
リンク元
Connection: close