TrickDiary このページをアンテナに追加 RSSフィード

2008-04-10

[][] if (0 == obj.size()) → if (obj.empty())

直感的に理解しやすいコーディングスタイルを心がけてるんで "0 == ..." っていうイディオムは直感的で気に入ってて obj.empty() よりも好んで使ってたんですが、残念ながら obj.size() を利用するのは時として obj.empty() を利用するよりもパフォーマンス的に劣悪な選択となるケースが存在します。そこで for 文でイテレータの動作を考慮し i++ の変わりに ++i で統一するように、これからは if (obj.empty()) で統一することを表明します。