Hatena::ブログ(Diary)

iDeaList::Writing このページをアンテナに追加 RSSフィード

2012-03-21

[][]2012年1月に株式会社を作りました\(^o^)/

フリーランスエンジニアとして独立して約2年が経ち、ようやく株式会社ステラート (英語表記:STELLATO, inc.)を設立しました。

内容が重複してしまいますので、詳しくは私的なほうのブログを参照してください><

思いの外、心の中をぶっちゃけた内容になってしまったためにエントリーはこちらで公開するのをやめました。

リンク見るのめんどくさい人に向けて2行で要約すると

とりあえず社名をパンチラかステラートで悩んでステラートという名前を選びましたよー。

アダルト系よりもイタリア語でオシャレぶりましたw ワロスwww という感じです!

はてダは去年よりもう少し頻度を上げて、なるべく有益な技術情報載せていくよう続けていきたいと考えています!

今はcocos2dやObjective-Cのできるひとたちとハッカソンしたい!もっと精進します!てへぺろ(・ω<)☆


Heart Beat » 2012年1月に株式会社を設立しました

2012-02-15

[][]さくらレンタルサーバ(スタンダード)のPython2.7対応

気付いたら勝手にバージョンアップをしていて、そのたびにpythonが動かなくなってる。(通算2回目)*1

virtual pythonをバージョン2.7で入れなおすことが必要です。自分用メモ。

こんなエラー

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
Traceback (most recent call last):
  File "/home/hoge/src/flaskr.py", line 12, in <module>
    from __future__ import with_statement
ImportError: No module named __future__

解決方法

cd ~/local/src
wget http://peak.telecommunity.com/dist/virtual-python.py
python2.7 virtual-python.py --prefix=~/local

#実行結果
Creating /home/acotie/local/lib/python2.7
Creating /home/acotie/local/lib/python2.7/site-packages
Creating /home/acotie/local/include/python2.7
Copying /usr/local/bin/python2.7 to /home/acotie/local/bin
You're now ready to download ez_setup.py, and run
/home/acotie/local/bin/python ez_setup.py

%cd ~/local/src
%wget http://peak.telecommunity.com/dist/ez_setup.py
%python ez_setup.py --prefix=~/local


参考サイト

[]macのステータスバーのdolipoとGoogle日本語入力アイコン変更

macのステータスバー


dolipoもモノクロがいいなーと思い、dolipo.tiffを変更した。

バックアップ

cp /Applications/dolipo.app/Contents/Resources/dolipo.tiff  /path/to/

変更したファイルを上書きするだけ

cp ~/Downloads/dolipo.tiff  /Applications/dolipo.app/Contents/Resources/



ついでにGoogle日本語入力も再インストールしたらアイコンが元に戻ってしまったのでメモ。

Example Domainから画像達をzip形式でダウンロード

cd /Library/Input\ Methods/GoogleJapaneseInput.app/Contents/Resources
open .

でごそっとコピー。

*1Perlも以前バージョン上がってて困ったことがあった気がする。もう新規で500円サーバは使いません><

2011-11-22

[]Tech総研主催、勝間和代さん、Mashup Award関連の女性限定イベントがあります

告知です。11/24(木)19:00〜@銀座7丁目のリクルート メディアテクノロジーラボ(MTL)CafeにてキャリアについてLTをさせて頂くことになりました。

大好評だった前回同様、今回も非常にアツイです。



名称:MUP48×勝間和代さん×Tech総研 IT女子会

日時:2011/11/24(木) 19:00-21:30くらい

場所:リクルート メディアテクノロジーラボ(MTL)Cafe

住所: 東京都中央区銀座7-2-6 リクルートアネックス1ビル B1F

交通:地下鉄銀座」駅(C3出口)徒歩約5分、JR地下鉄新橋」駅(銀座口)徒歩約7分

費用:無料

主催:Tech総研

協賛:株式会社リクルート

公式ハッシュタグ:#MUP48

#MUP48 第2回IT女子会★MUP48×勝間和代さん×Tech総研★ : ATND



勝間和代さんファン必見、トークセッションもあります。

テーマは、「キャリアを支えるSNS 〜キャリア形成、セルフブランディングSNSをどう使う?〜」。

カツマーっぽい人にDisられないように、漠然とした精神論ではなく

今までの失敗や体験から学んだ具体的な方法論をお話しする予定です!

資料は公開しないのでここだけ限定です(^^)

日本で唯一、おいしいワインが飲めるイベントはこれだけ!!w

懇親会でお会いしましょう!


↓ こちらから参加登録できます! ↓

#MUP48 第2回IT女子会★MUP48×勝間和代さん×Tech総研★ : ATND

2011-11-15

[][]EC2上のCentOSnode.jsのsocket.ioをインストールしようとした際のエラー

npmでsocket.ioがインストールできない!と思ったらデフォルトtar (GNU tar) 1.15.1だとダメだったというだけのメモ。


$ npm install socket.io
npm ERR! Failed unpacking /tmp/npm-1319403120027/1319403120088-0.7213427403476089/tmp.tgz
npm ERR! couldn't unpack /tmp/npm-1319403120027/1319403120088-0.7213427403476089/tmp.tgz to /tmp/npm-1319403120027/1319403120088-0.7213427403476089/contents
npm ERR! error installing socket.io-client@0.8.5 Error: `tar "-zmvxpf" "/tmp/npm-1319403120027/1319403120088-0.7213427403476089/tmp.tgz" "-o"`
npm ERR! error installing socket.io-client@0.8.5 failed with 2
npm ERR! error installing socket.io-client@0.8.5     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/tar.js:219:20)
npm ERR! error installing socket.io-client@0.8.5     at ChildProcess.emit (events.js:67:17)
npm ERR! error installing socket.io-client@0.8.5     at ChildProcess.onexit (child_process.js:192:12)
npm ERR! error installing socket.io@0.8.5 Error: `tar "-zmvxpf" "/tmp/npm-1319403120027/1319403120088-0.7213427403476089/tmp.tgz" "-o"`
npm ERR! error installing socket.io@0.8.5 failed with 2
npm ERR! error installing socket.io@0.8.5     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/tar.js:219:20)
npm ERR! error installing socket.io@0.8.5     at ChildProcess.emit (events.js:67:17)
npm ERR! error installing socket.io@0.8.5     at ChildProcess.onexit (child_process.js:192:12)
npm ERR! Error: `tar "-zmvxpf" "/tmp/npm-1319403120027/1319403120088-0.7213427403476089/tmp.tgz" "-o"`
npm ERR! failed with 2
npm ERR!     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/tar.js:219:20)
npm ERR!     at ChildProcess.emit (events.js:67:17)
npm ERR!     at ChildProcess.onexit (child_process.js:192:12)
npm ERR! Report this *entire* log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>   
npm ERR!
npm ERR! System Linux 2.6.18-194.el5xen
npm ERR! command "node" "/usr/local/bin/npm" "install" "socket.io"
npm ERR! cwd /root/src/chat-node
npm ERR! node -v v0.4.12
npm ERR! npm -v 1.0.101
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /root/src/chat-node/npm-debug.log
npm not ok



まさにこのとおり。

What does tar --version output? If it's gnutar 1.15 or so, you need to upgrade to something more modern. I've been told by other CentOS users that 1.15.1 is the newest rpm available, so you may need to build from source.

https://github.com/isaacs/npm/issues/1559


デフォルトのバージョンは1.15.1

$ tar --version
tar (GNU tar) 1.15.1

最新の1.26をダウンロード&インストール

$ wget http://ftp.gnu.org/gnu/tar/tar-1.26.tar.gz
$ tar -xzvf tar-1.26.tar.gz
$ cd tar-1.26
$ ./configure FORCE_UNSAFE_CONFIGURE=1
$ make 
$ make install

できたできた

$ npm install socket.io
socket.io@0.8.5 ./node_modules/socket.io 
├── redis@0.6.6
├── policyfile@0.0.4
└── socket.io-client@0.8.5

[]Lionアップデート後にcpanmでエラー

自分用メモ。

This distribution requires a C compiler, but it's not available, stopped.

とか

/usr/bin/gcc-4.2 -c   -pipe -O2 -arch x86_64 -fno-common -DPERL_DARWIN -I/opt/local/include -no-cpp-precomp -fno-strict-aliasing -I/opt/local/include -O3   -DVERSION=\"2.22\" -DXS_VERSION=\"2.22\"  "-I/opt/local/lib/perl5/5.8.9/darwin-2level/CORE"   Stash.c
/bin/sh: /usr/bin/gcc-4.2: No such file or directory
make[1]: *** [Stash.o] Error 127
make: *** [subdirs] Error 2

ひたすらCのコンパイラがないよ!って怒られてビルドできなかったので、macportsgccを別途インストールしても動かなくて探してたら同じ現象の人がいた。

OSX 10.7 Lion にアップグレード後に壊れたPerl / cpanm 環境を復旧する - Goodpic


Xcode 4.2からGCC 4.2のサポートされなくなったようで、Lionアップグレードするとgccが消えてしまうらしい。

kennethreitz/osx-gcc-installer ? GitHubからOS X 10.7 Lion: GCC-10.7.pkgを探してダウンロード&インストール

2011-10-21

[]はてな東京オフィスでランチをご一緒させて頂きました

2週間くらい前に、前回のPR記事のフィードバック頂くために、ご挨拶を兼ねてオフィスにお邪魔してきました!

高野さんやきよへろさんがIMで声を掛けてくださったようで

京都オフィスとポリコムでつないでid:rikoさんとid:nagayamaさんともお話しすることができました!(写真のテレビ画面に映っているのはid:rikoさん)

お忙しいところありがとうございます!

hatena


この日のランチは近くのカフェから取り寄せたものとのことで、オシャレなワンプレート + 野菜たっぷりスープ + デザートの栗が入ったパウンドケーキ という

理想的なバランスでゴハンを頂くことができました!みなさんの和の中に混じってファミコンとかマンガの話をしていました。

ファミコンジャンプとか聖闘士星矢とかドラゴンボールとかダイの大冒険とかアツイです。*1

hatena


今回、約4年ぶりの再会を果たせた東京オフィス勤務のid:kiyoheroさんも私のことを覚えてくださっていました!

私も4年前は某氏の家でよく集まって飲んでましたよねー!あの頃が懐かしいですね!と、少しノルスタジーに浸っていました。*2

ネットで繋がっていると、全然会っていないという感じがしないのは私だけでしょうか。

はてなさんの新しいステッカーをid:kiyoheroさんから頂きました。第1号らしいです!YAPC::Asia2011でステッカーもらえましたか?


はてなという会社はどんなに人が増えてもあたたかいイメージで、本当にほっこりしました!!

ちょっと知り合いで優しくしてくれたから.....言っておこうとかそんな表面的なものじゃないです。

はてなという会社のすごいところは技術ももちろんすごいのですが、社員のみなさんが本当に会社のことが大好きなんですよね。

サービスへの愛情も深いし、言わずして伝わってくる空気感や雰囲気があるのです。

会社の一番の商品は人だ、というサービス業で使われる言葉がありますが、まさに体現されている会社だと思います。

CS・ESを強く意識されている経営者や人事担当者は、はてなさんを分析されるといいと思います。

あと営業の方は、はてなさんの広告モデルやビジネスアプローチでどういう風に成功しているのか分析されると、いかに営業的にも優秀なのかが理解できて面白いと思います。


終始浮き足立つようなミーハーな感じ + 内輪ノリな読みにくい文章になってしまいましたが

今年の2月頃からランチのお話があったものの色々バタついて、ようやく実現したのが今年の10月。

約8ヶ月越しの願いが叶ったので嬉しくてブログに書いてしまいました。

id:mtakanoさん、貴重な機会をありがとうございます!

*1ダイの大冒険アニメで観てたし、ファミコンの話にでてきたソフトは実家で全部持っていて、クリアできなさすぎてイライラしてコントローラーを投げたことが何回もありますw

*2:ごく一部のはてなtwitter界隈のユーザで飲み会や鍋会、wiiでゲーム大会など、ほぼ毎日なにかが行われていました。誰かしら必ず家に集まっているプチシェアハウス状態でした。